#1 [↑][↓]  11-07-2018 08:44:59

platoplotinus
Copilote
Date d'inscription: 13-03-2008
Renommée :   11 

[Résolu][FSX] Problème avec HELX de SDG + décor photo réaliste

bonjour à tous les amis wink

De nouveau ce matin, un appel à vos lumières, et toujours en  relation avec l'Egypte que je "monte" actuellement en décors photo réalistes.

Il s'agit cette fois du secteur de l'aéroport de LUXOR (HELX).

L'aéroport par défaut s'intègre plutôt bien à la scène photor réaliste que j'ai créée, mais il reste très sommaire et générique. donc j'ai souhaité l'ugrader.

Dans un premier temps, j'ai installé la version freeware, disponible à la fois sur flighsim et avsim. Grosse déception car les bâtiments ont leurs structures verticales qui disparaissent et réapparaissent continuellement, donnant alors le sentiment que le haut des bâtiments flotte en l'air. J'ai testé sur 2 Pc différents, et j'ai obtenu le même résultat négatif. J'en conclus qu'il y a un problème avec les textures de cette scène (qui serait assez belle autrement) et je l'ai désinstallée.

Je suis alors passé à la version Payware de SDG, disponible sur Simmarket. Il s'agit d'une scène assez bien  réussie, et d'un prix très modique (moins de 10 euros). Mais lorsque je la couple avec mon décor photo réaliste, j'obtiens un effet désagréable que vous allez voir sur deux de mes captures d'écran (les deux autres sont simplement pour illustration). Je constate en effet la présence d'une énorme route liée à deux bretelles qui permettent de sortir de l'aéroport, et cette route cisaille de manière très laide le décor photo réaliste, à la fois par son caractère massif, primitif, et par le fait qu'elle ne cadre avec aucune route effectivement existante sur le décor photo réaliste.

J'ai donc essayé de la neutraliser. Et c'est là que les difficultés commencent... Je dois, pour être aussi clair que possible,  vous signaler deux choses :

1) Pour des raisons que je ne m'explique pas - mais que vous allez certainement me dire, si vous savez - les bgl de cette scène sont totalement "anonymisés" (du type SDGLXA101.bgl jusqu'à SDGLXA193.bgl), de telle sorte qu'on ne peut pas se fonder sur leur dénomination pour essayer de déterminer lequel ou lesquels de ces bgl anonymes doivent être neutralisés. De même l'AFCAD n'est pas nommé explicitement e_colere3, où il est dissimulé anonymement ailleurs lors de l'installation. Et il n'y a aucun readme.txt d'accompagnement, ni le moindre dossier PDF. Assez "cavalier" comme procédé !!!! e_colere3 angryfire_b1_d_gif

2) Ceci m'amène au deuxième aspect de la scène, qui m'agace, même si je crois en comprendre les raisons. Son installation est automatique, après achat normal (j'insiste, sur l'achat 'normal'), mais passablement "tordu". Et surtout (je suppose que c'est la raison de la procédure adoptée), il est impossible, une fois l'aéroport installé sur un PC, de l'installer sur un autre, même avec la même adresse e-mail, et la même clef fournie. Si l'on tente l'opération, on a droit à un "beau" message, indiquant que la clef n'a pas pu être activée, et de passer par le site pour obtenir sa réactivation. L'équipe semble très "névrosée" à l'égard du piratage (une seule installation admise !!!), mais... bon.... Et si, maintenant, l'on fait un copier-coller de l'ensemble de la scène d'un PC à l'autre, seules les pistes et le décor photoréaliste (réduit et sombre - au passage, je signale que la scène de l'aérodrome du Caire, crée par le même groupe, à 25 euros cette fois  (!!!) sur Simmarket, fait la quasi uanimité contre elle pour la médiocrité sombre de ses décors... Dont acte....) apparaissent et aussi apparaît la "fameuse" route laide dont on se passerait bien...), mais pas les bâtiments. Sans doute faut-il d'abord la désinstaller 'proprement', en passant par l'installateur automatique, pour pouvoir soi-même la réinstaller ailleurs. Ouuuuuufffff e_Clown (en revanche, sur un même pc, elle peut être déplacée, du répertoire racine de FSX où elle se place autoritairement, vers un autre "path", en modifiant l'entrée en conséquence)...

Bref, j'ai fait quelques tentatives "empiriques" pour garder le décor tout en neutralisant cette foutue route qui cisaille mon décor photoréaliste. Echec et mat jusqu'à présent...

Alors je demande à ceux d'entre vous, plus experts que moi en bgls, et qui auraient la scène (à ceux qui ne l'ont pas aussi !) de m'indiquer une piste s'ils savent. Merci d'avance, une fois enciore, pour l'entraide apportée wink

Illustrations promises pour finir :

Deux captures d'écran purement illustratives :

https://imagizer.imageshack.com/v2/xq90/922/W09xSv.jpg

https://imagizer.imageshack.com/v2/xq90/922/QSgP84.jpg


Deux captures d'écran, où vous allez voir (un peu) la "fameuse" route parasite (je peux faire mieux si vous souhaitez !!!)

https://imagizer.imageshack.com/v2/xq90/921/uNoen7.jpg

https://imagizer.imageshack.com/v2/xq90/924/l6itR6.jpg


En toute amitié à tous et bons vols.


Platoplotinus

Jean-Yves

Dernière modification par platoplotinus (Hier 06:35:25)

Hors ligne

 

#2 [↑][↓]  Hier 07:07:16

platoplotinus
Copilote
Date d'inscription: 13-03-2008
Renommée :   11 

Re: [Résolu][FSX] Problème avec HELX de SDG + décor photo réaliste

Rebonjour à tous les amis ce matin wink

Comme promis, je reviens vous donner les dernières nouvelles relatives à ce post resté en souffrance et sans aucune réponse, depuis plusieurs jours (aucun d'entre vous ne savait, je pense...) et vous pouvez voir que je viens de le mettre comme "Résolu". eusa_clap

Une bonne chose certes, mais en même temps, pour moi, l'occasion d'une nouvelle interrogation, et d'un questionnement vers vous wink

Je m'explique...

J'ai continué, de mon côté, mes recherches sur la scène, et j'ai fini par voir, en m'aidant de ADE, que le fichier AFCAD était constitué, dans cette scène où tout est fâcheusement anonymisé e_colere3 par le fichier nommé HELX_ADEXèADE.bgl (pourquoi diable les auteurs n'ont-ils pas marqué explicitement que c'est un ADFCAD, une chose aussi que je voudrais bien savoir)...

J'ai donc décidé d'examiner le contenu de ce fichier et je l'ai ouvert, puis mis à l'écran, avec ADE afin d'examiner son contenu précis.

En même temps, j'ai vu que les "routes" que je voulais faire disparaître du décor photoréaliste étaient constituées d'une succession d'Aprons.

Me souvenant alors d'un conseil donné dans le passé et en privé par notre ami PatDeBarr (merci de noueau au passage à lui, si d'aventure, il lit ce post), à qui j'avais demandé le moyen de faire disparaître des pistes et des aprons qui ne cadrent pas avec le déocr photoréaliste, sans pour autant les détruire, j'ai appliqué la technique qu'il m'avait alors conseillée, à savoir dans la fenêtre "Properties" de chaque Apron, de décocher les deux cases "Draw Surface et "Draw Détails", j'ai fait Ok pour chacun d'entre eux. J'ai compilé dans ADE, et obtenu un fichier bgl (HELX_ADEX_JYB.bgl, que j'ai placé dans Addon Scenery/scenery, puis mis en bak le fichier HELX_ADEX_ADE.bgl de la scène. Tout s'est semble-t-il bien passé, sauf qu'à l'ouverture de la scène, dans FSX, rien n'avait changé. tous les bâtiments étaient présents (bonne chose), mais aussi "mes" routes parasites étaient toujours là ! angryfire_b1_d_gifangryfire_b1_d_gifangryfire_b1_d_gif

J'ai répété plusieurs fois l'opération, pensant avoir fait une erreur de manipulation, et avec toujours la même "punition" au terme, après cçompilation. La scène restait à l'identique.

Dans ces conditions, j'ai utilisé une autre technique, plus brutale : dans le fichier HELX_ADEX_JYB.bgl, créé par ADE, j'ai fait patiamment "Delete Object" pour chacun des Aprons parasites, compilé, enregistré et replacé le fichier en question modifié en conséquence, dans Addon Scenery\scenery. Et cette fois tout est nickel, comme vous pouvez le voir sur les captures d'écran ci-dessous... Et comme j'ai gardé prcieusement le fichier originel de la scène, je n'aurai aucun problèm, si je veux revenir en arrière dans le futur, et remettre en place ces routes qui jurent dans le décor photoréaliste.

Reste que je voudrais bien comprendre le pourquoi du comment... D'autant plus qu'il me revient en mémoire, maintenant, qu'il m'est arrivé de constater la même anomalie, dans le passé, en voulant "alléger" certains petits aéroports "perdus". Le gommage de la piste, selon le même procédé (fenêtre "Properties" de la piste : Activer la case "Transparence"), a toujours fonctionné sans problème. Mais pour les Aprons, il y eut des succès (sur certains aéroports) et des échecs que je ne m'explique pas (sur d'autres). Pourriez-vous m'éclairer là-dessus ? Car j'aime bien comprendre quand je constate une étrangeté de ce genre.

https://imagizer.imageshack.com/v2/xq90/923/7MwrTb.jpg

https://imagizer.imageshack.com/v2/xq90/923/iGHxsq.jpg

https://imagizer.imageshack.com/v2/xq90/921/w78QSy.jpg


Merci d'avance pour vos réponses. Et je précise à l'intention de nos amis Bede40 et Lagaffe, que je reviens aussi, sous peu et comme promis, sur le secteur du Caire, pour décrire la situation actuelle relative aux routes et aux points parasites. Là aussi, il y a du bon (enfin, du mieux...), et du moins bon... et des questions en suspens !!! sad


En toute amitié à tous wink

Et bons vols.

Jean-Yves

Dernière modification par platoplotinus (Hier 07:18:37)

Hors ligne

 

Pied de page des forums

Maintenance informatique Lausanne